Edge Router Reconnect

Occasionally the Edge Router will loose the PPPoE connection, and won't automatically get it back.

Login via SSH and run the following:

disconnect interface pppoe0
connect interface pppoe0

Inspecting the logs can help to identify the issue.

I suspect that LCP ConfReq lines are relevant - see the repeats before pppoe0 is disconnected in the sample output below.

show interfaces pppoe pppoe0 log
Script /etc/ppp/ip-up finished (pid 28032), status = 0x0
No response to 6 echo-requests
Serial link appears to be disconnected.
ipcp: down
Connect time 2817.2 minutes.
Sent 1993321421 bytes, received 543302134 bytes.
Script /etc/ppp/ip-down started (pid 17548)
sent [LCP TermReq id=0x5d "Peer not responding"]
sent [LCP TermReq id=0x5e "Peer not responding"]
Connection terminated: no multilink.
Modem hangup
Script /etc/ppp/ip-down finished (pid 17548), status = 0x0
Connected to 00:1d:aa:8a:7b:6c via interface eth2
using channel 18
Using interface ppp0
Connect: ppp0 <--> eth2
sent [LCP ConfReq id=0x5f <magic 0xe226f89a>]
sent [LCP ConfReq id=0x5f <magic 0xe226f89a>]
sent [LCP ConfReq id=0x5f <magic 0xe226f89a>]
sent [LCP ConfReq id=0x5f <magic 0xe226f89a>]
sent [LCP ConfReq id=0x5f <magic 0xe226f89a>]
[...]
sent [LCP ConfReq id=0x5f <magic 0xe226f89a>]
sent [LCP ConfReq id=0x5f <magic 0xe226f89a>]
sent [LCP ConfReq id=0x5f <magic 0xe226f89a>]
sent [LCP ConfReq id=0x5f <magic 0xe226f89a>]
sent [LCP ConfReq id=0x5f <magic 0xe226f89a>]
Thu Apr 28 11:12:05 UTC 2016: User attie stopping PPP daemon for pppoe0 by disconnect command
Terminating on signal 15
sent [LCP TermReq id=0x60 "User request"]
sent [LCP TermReq id=0x61 "User request"]
Connection terminated: no multilink.
Modem hangup
Thu Apr 28 11:12:34 UTC 2016: User attie starting PPP daemon for pppoe0 by connect command
Connected to 10:e8:78:a7:b9:65 via interface eth2
using channel 19
Using interface ppp0
Connect: ppp0 <--> eth2
sent [LCP ConfReq id=0x1 <magic 0x82d50e53>]
rcvd [LCP ConfReq id=0xef <mru 1500> <auth chap MD5> <magic 0x6fec38ea>]
lcp_reqci: returning CONFACK.
sent [LCP ConfAck id=0xef <mru 1500> <auth chap MD5> <magic 0x6fec38ea>]
rcvd [LCP ConfAck id=0x1 <magic 0x82d50e53>]
sent [LCP EchoReq id=0x0 magic=0x82d50e53]
rcvd [CHAP Challenge id=0x1 <d574496ce47a959db06c3e1bab4361916ee44dc0af38bfc879df7b62691be1be8f>, name = "${server_name}"]
sent [CHAP Response id=0x1 <afc2b40976c000365247f7d829893728>, name = "${account_username}"]
rcvd [LCP EchoRep id=0x0 magic=0x6fec38ea]
rcvd [CHAP Success id=0x1 "CHAP authentication success"]
CHAP authentication succeeded: CHAP authentication success
CHAP authentication succeeded
peer from calling number 10:E8:78:A7:B9:65 authorized
sent [IPCP ConfReq id=0x1 <addr 0.0.0.0>]
rcvd [IPV6CP ConfReq id=0xb2 <addr fe80::0221:05ff:fead:9024>]
Unsupported protocol 'IPv6 Control Protovol' (0x8057) received
sent [LCP ProtRej id=0x2 80 57 01 b2 00 0e 01 0a 02 21 05 ff fe ad 90 24]
rcvd [IPCP ConfReq id=0x8e <addr yy.yy.yy.yy>]
ipcp: returning Configure-ACK
sent [IPCP ConfAck id=0x8e <addr yy.yy.yy.yy>]
rcvd [IPCP ConfNak id=0x1 <addr xx.xx.xx.xx>]
sent [IPCP ConfReq id=0x2 <addr xx.xx.xx.xx>]
rcvd [IPV6CP TermReq id=0xb3]
Unsupported protocol 'IPv6 Control Protovol' (0x8057) received
sent [LCP ProtRej id=0x3 80 57 05 b3 00 04]
rcvd [IPCP ConfAck id=0x2 <addr xx.xx.xx.xx>]
ipcp: up
Script /etc/ppp/ip-pre-up started (pid 21919)
Script /etc/ppp/ip-pre-up finished (pid 21919), status = 0x0
local  IP address xx.xx.xx.xx
remote IP address yy.yy.yy.yy
Script /etc/ppp/ip-up started (pid 21984)
rcvd [IPV6CP TermReq id=0xb4]
Unsupported protocol 'IPv6 Control Protovol' (0x8057) received
sent [LCP ProtRej id=0x4 80 57 05 b4 00 04]
Script /etc/ppp/ip-up finished (pid 21984), status = 0x0